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DWGSee

 

DWGSee is comprehensive software for viewing, printing, marking and sharing DWG files. It is fast, powerful and 

easy-to-use for every expert and beginners.

  

Starting DWGSee 

After you install DWGSee on your computer, 

double-click the DWGSee icon to open the program.

 

File operation 

 

� Batch printing 

Varieties of work can be done in a few minutes 

and print them. (Kindly notice: this may consume a lot of paper, which is not environmentally friendly, please think 

twice before doing this.) 

 

Here we go 

 

STEP1. 

Go to “File” > “Batch Print”.  
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DWGSee User Guide 

DWGSee is comprehensive software for viewing, printing, marking and sharing DWG files. It is fast, powerful and 

use for every expert and beginners. 

After you install DWGSee on your computer, there is an application icon placed on the desktop and in the Start menu, 

click the DWGSee icon to open the program. 

Varieties of work can be done in a few minutes by DWGSee, just select the files, set up layouts and model space, 

indly notice: this may consume a lot of paper, which is not environmentally friendly, please think 

http://www.autodwg.com 

DWGSee is comprehensive software for viewing, printing, marking and sharing DWG files. It is fast, powerful and 

placed on the desktop and in the Start menu, 

 

by DWGSee, just select the files, set up layouts and model space, 

indly notice: this may consume a lot of paper, which is not environmentally friendly, please think 
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If you are in the DWGSee “Browser Mode”:

Option1. Go to “File” > “Batch Print” 

Option2. Hold “Ctrl” and click the drawings that you need one by one in current folder, when finished, right click on 

any of the highlighted file and select “Batch

AutoDWG DWGSee DWG Viewer 

- 2 - 

AutoDWG   Email: info@autodwg.com   http://www.autodwg.com

 

If you are in the DWGSee “Browser Mode”: 

 

 

Option2. Hold “Ctrl” and click the drawings that you need one by one in current folder, when finished, right click on 

any of the highlighted file and select “Batch Print” 

http://www.autodwg.com 

Option2. Hold “Ctrl” and click the drawings that you need one by one in current folder, when finished, right click on 



Copyright 2001-2015 AutoDWG   Email: 

STEP2. 

Press “Add” and choose a bunch of files to the print list, you may select bulk layouts to be printed.

Note: You may also use the “Layout Select” button to choose “Paper Space”, “Model Space” 

 

Note: You may also set the number of copies, print in black and white, etc. in the other two tabs “Print Scale” and “Line Width”.
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Press “Add” and choose a bunch of files to the print list, you may select bulk layouts to be printed.

You may also use the “Layout Select” button to choose “Paper Space”, “Model Space” and

set the number of copies, print in black and white, etc. in the other two tabs “Print Scale” and “Line Width”.

http://www.autodwg.com 

Press “Add” and choose a bunch of files to the print list, you may select bulk layouts to be printed. 

 

and “All Layouts” in one go. 

set the number of copies, print in black and white, etc. in the other two tabs “Print Scale” and “Line Width”. 
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STEP3. 

If it is the first time you use the DWGSee print function, please click “Print Setup” to set the printer properties, or 

just press the “Print” button and wait for your papers.

 

� Search texts in multiple drawings

It is an advanced feature available in the “Brower mode” for text searching of multiple drawings in folder and its 

subfolder. DWGSee will go through all the drawing file for 

 

Here we go. 

 

STEP1. 

Option1. Go to the “Find” button on the navigation bar. 

 

Option2. Go to “Tools” > “Find”. 

Option3. Hold “Ctrl” and press “F” on your keyboard.
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If it is the first time you use the DWGSee print function, please click “Print Setup” to set the printer properties, or 

the “Print” button and wait for your papers. 

 

Search texts in multiple drawings 

It is an advanced feature available in the “Brower mode” for text searching of multiple drawings in folder and its 

subfolder. DWGSee will go through all the drawing file for the matched text. 

Option1. Go to the “Find” button on the navigation bar.   

 

  

Option3. Hold “Ctrl” and press “F” on your keyboard. 
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If it is the first time you use the DWGSee print function, please click “Print Setup” to set the printer properties, or 

It is an advanced feature available in the “Brower mode” for text searching of multiple drawings in folder and its 
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STEP2. 

Type what text you want to find then click “OK”. 

Example: 

In this example, I would like to see where Jane’s desk is in our new working place, so I enter “Jane” in 

and finally located Jane.

 

� Save DWF as a DWG or DXF 

Drawing can be digitized and vectorized, DWF can also be back to DWG and DXF. Use DWGSee to convert DWG 

to DXF, DXF to DWG, DWG to DWF, DXF to DWF, DWF to DWG and DWF to DXF. When complete, click “save as” 

and you’ll get it. 

 

Here we go. 
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Type what text you want to find then click “OK”. The search results are limit to current space (model or layout).

In this example, I would like to see where Jane’s desk is in our new working place, so I enter “Jane” in 

be digitized and vectorized, DWF can also be back to DWG and DXF. Use DWGSee to convert DWG 

to DXF, DXF to DWG, DWG to DWF, DXF to DWF, DWF to DWG and DWF to DXF. When complete, click “save as” 

http://www.autodwg.com 

The search results are limit to current space (model or layout).

 

In this example, I would like to see where Jane’s desk is in our new working place, so I enter “Jane” in the textbox 

 

be digitized and vectorized, DWF can also be back to DWG and DXF. Use DWGSee to convert DWG 

to DXF, DXF to DWG, DWG to DWF, DXF to DWF, DWF to DWG and DWF to DXF. When complete, click “save as” 
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STEP1. 

Open a DWF file, go to “File” > “Save as a copy” or click the “Save as” button on the navigation bar.

 

STEP2. 

In the open “Save as” window, give the new drawing file a name and from the drop down menu of the “Save as 

type”, select DWG or DXF format and the CAD version.

click “OK”. 

 

� Browser mode advanced features

DWGSee browser is independent of AutoCAD. It is not only a drawing file viewer, but also featured with advanced 

functions. You can quickly add markups and

image using the export feature and etc.

In Brower mode, you can batch print and search text in multiple drawings and compare differences between two 

drawings. 

 

Here we go. 
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go to “File” > “Save as a copy” or click the “Save as” button on the navigation bar.

 

In the open “Save as” window, give the new drawing file a name and from the drop down menu of the “Save as 

type”, select DWG or DXF format and the CAD version. Choose where you want to keep the new drawing file and 

Browser mode advanced features 

DWGSee browser is independent of AutoCAD. It is not only a drawing file viewer, but also featured with advanced 

functions. You can quickly add markups and print, easily count entities in drawing, simply convert files into PDF or 

image using the export feature and etc. 

In Brower mode, you can batch print and search text in multiple drawings and compare differences between two 

http://www.autodwg.com 

go to “File” > “Save as a copy” or click the “Save as” button on the navigation bar. 

 

In the open “Save as” window, give the new drawing file a name and from the drop down menu of the “Save as 

Choose where you want to keep the new drawing file and 

 

DWGSee browser is independent of AutoCAD. It is not only a drawing file viewer, but also featured with advanced 

print, easily count entities in drawing, simply convert files into PDF or 

In Brower mode, you can batch print and search text in multiple drawings and compare differences between two 
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Batch print 

Reading docs on screen could be challenging, DWGSee can batch print DWG/DXF/DWF docs by the sequence 

you chose. 

 

Search text 

DWGSee will go through all chosen directories and list all matched result for your check. You may open anyone 

and click “Next drawing” and “Previous drawing” to view quickly.

     

Compare 

Select two drawing files and enable the instant visual comparison. DWGSee Compare automatically measure, 

rotate and align two drawing revisions and highlight all differences with dash squares. 

entities, modified entities and deleted entities and marked with different colors.

 

� Go to Browser 

A DWGSee browser is a drawing file manager for AutoCAD drawings such as DWG, DXF and DWF. You can 

quickly view, search, markup, print, compare and share drawing designs, with no advanced CAD expertise 

required. 

 

Here we go. 

 

Option1. Go to “File” > “Browser”. 

Option2. Press “Ctrl” and press “B” on your keyboard.
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Reading docs on screen could be challenging, DWGSee can batch print DWG/DXF/DWF docs by the sequence 

DWGSee will go through all chosen directories and list all matched result for your check. You may open anyone 

drawing” and “Previous drawing” to view quickly. 

Select two drawing files and enable the instant visual comparison. DWGSee Compare automatically measure, 

rotate and align two drawing revisions and highlight all differences with dash squares. 

entities, modified entities and deleted entities and marked with different colors. 

A DWGSee browser is a drawing file manager for AutoCAD drawings such as DWG, DXF and DWF. You can 

int, compare and share drawing designs, with no advanced CAD expertise 

 
Option2. Press “Ctrl” and press “B” on your keyboard. 

http://www.autodwg.com 

Reading docs on screen could be challenging, DWGSee can batch print DWG/DXF/DWF docs by the sequence 

DWGSee will go through all chosen directories and list all matched result for your check. You may open anyone 

Select two drawing files and enable the instant visual comparison. DWGSee Compare automatically measure, 

rotate and align two drawing revisions and highlight all differences with dash squares. They are categorized in new 

A DWGSee browser is a drawing file manager for AutoCAD drawings such as DWG, DXF and DWF. You can 

int, compare and share drawing designs, with no advanced CAD expertise 
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Option3. Find the “Browser” button on the toolbar.

Basic features 

Browse 

DWGSee allows browsing the local directory hierarchy 

list all the drawing files in the right viewer.

Manage 

To manage the files in the view, you may right click on any 

the available operations.  

It allows browsing in different views, which differ in their usage of icons.

Files can also be viewed, copied, moved, deleted, renamed or send as email attachment.
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Option3. Find the “Browser” button on the toolbar. 

 

DWGSee allows browsing the local directory hierarchy – you may select folders in the file browser window and it will 

list all the drawing files in the right viewer. 

To manage the files in the view, you may right click on any drawing thumbnail or anywhere in the viewer to check 

It allows browsing in different views, which differ in their usage of icons.  

Files can also be viewed, copied, moved, deleted, renamed or send as email attachment.

  

http://www.autodwg.com 

you may select folders in the file browser window and it will 

 

drawing thumbnail or anywhere in the viewer to check 

Files can also be viewed, copied, moved, deleted, renamed or send as email attachment. 
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Advanced features 

It is not enough to be a high quality drawing viewer with the basic features. And more advanced features are 

provided in the Browser mode. 

 

Markup 

 

� DWGSee Markup 

Drawing file can be transferred everywhere, and they can be back with markups. 

markups, so that markups will not affect the original. Markup overlays are saved in separate *.mrk file. The 

reviewer can just send you back the *.mr

 

Here we go. 

 

For this demonstration, you will have a glance of how DWGSee markup collaborates and coordinates with the 

drawings. 

 

Open/save/close markup 

In DWGSee, measure and markup tools are saved in the Markup menu, so both measures and markups are 

stored in the same *.MRK file once you clicked 

To open an existing markup, please go to “File” > “Open Markup …”

To close an open markup, please go to “File” > “Close Markup…”

To save the current markup, please go to “File” > “Save Markup…”
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It is not enough to be a high quality drawing viewer with the basic features. And more advanced features are 

Drawing file can be transferred everywhere, and they can be back with markups. DWGSee creates overlays for 

markups, so that markups will not affect the original. Markup overlays are saved in separate *.mrk file. The 

reviewer can just send you back the *.mrk file for you to see remarks. 

ave a glance of how DWGSee markup collaborates and coordinates with the 

In DWGSee, measure and markup tools are saved in the Markup menu, so both measures and markups are 

stored in the same *.MRK file once you clicked “save markup”. 

To open an existing markup, please go to “File” > “Open Markup …” 

To close an open markup, please go to “File” > “Close Markup…” 

To save the current markup, please go to “File” > “Save Markup…” 
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It is not enough to be a high quality drawing viewer with the basic features. And more advanced features are 

DWGSee creates overlays for 

markups, so that markups will not affect the original. Markup overlays are saved in separate *.mrk file. The 

ave a glance of how DWGSee markup collaborates and coordinates with the 

In DWGSee, measure and markup tools are saved in the Markup menu, so both measures and markups are 
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Select a measure or drawing markup tool

Measure markups 

The tool of measure is for the distance between two points, angles between two unparallel lines and radius of a 

circle, an arc, a curve and an arch. You’ll have to choose these tools on the navigation bar to add measures.

 

Callout markups 

The Callout tool enables you to create a call

enter text in the call-out box for explanation.

 

Text box markup 

 

The Text Box tool is similar to the Callout tool, except it is 

drawing. You can enter text in the text box.

Free drawing markup 

It is like the actual drawing on paper, it can be divided into three types: Free Redline markup, Polyline markup and 

Rectangle markup. 
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Select a measure or drawing markup tool 

The tool of measure is for the distance between two points, angles between two unparallel lines and radius of a 

arch. You’ll have to choose these tools on the navigation bar to add measures.

The Callout tool enables you to create a call-out shape that points to a particular location in the drawing. You can 

out box for explanation. 

The Text Box tool is similar to the Callout tool, except it is only a text box that can be placed at any location on the 

drawing. You can enter text in the text box. 

It is like the actual drawing on paper, it can be divided into three types: Free Redline markup, Polyline markup and 

http://www.autodwg.com 

 

The tool of measure is for the distance between two points, angles between two unparallel lines and radius of a 

arch. You’ll have to choose these tools on the navigation bar to add measures. 

out shape that points to a particular location in the drawing. You can 

only a text box that can be placed at any location on the 

It is like the actual drawing on paper, it can be divided into three types: Free Redline markup, Polyline markup and 
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Tools 

 

� Compare drawing differences 

You may find it hard to recall the changes you made to the drawing file several days ago, don’t worry! DWGSee 

can list every change you made by comparing drawing differences. You can also use this feature to 

actions made by your teammates. 

 

Here we go. 

STEP1. 

Option1. Go to “Tools” > “DWG Compare…”

 

Option2. Press the “Find differences between versions” button on the tool bar.

If you are in the Browser mode, go to “File” > “DWG compare”.

STEP2. 

Click “…” buttons to add your 2 versions of drawing files. You may 

folder (default location: C:\Program Files (x86)
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You may find it hard to recall the changes you made to the drawing file several days ago, don’t worry! DWGSee 

can list every change you made by comparing drawing differences. You can also use this feature to 

Option1. Go to “Tools” > “DWG Compare…” 

 

Option2. Press the “Find differences between versions” button on the tool bar. 

 

If you are in the Browser mode, go to “File” > “DWG compare”. 

 

Click “…” buttons to add your 2 versions of drawing files. You may refer to examples in the DWGSee installation 

Program Files (x86)\AutoDWG\DWGSee Pro 2015). 

http://www.autodwg.com 

You may find it hard to recall the changes you made to the drawing file several days ago, don’t worry! DWGSee 

can list every change you made by comparing drawing differences. You can also use this feature to check the 

examples in the DWGSee installation 
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Note: Click the “Setting” button to find more compare options.

 

STEP3. 

Click “OK” to compare and highlight differences in two drawings.

 

� Text searching in AutoCAD drawing

No matter it is note, title block, or with pointer, DWGSee will help you locate and highlight it in the center of the 

screen and list the text in the right pane, you may select “Case Sensitive” and “Match Whole Word” to rest

results. 

 

Here we go. 

 

STEP1. 

Hold “Ctrl” and press “B” to go to the Browser mode.

 

STEP2. 

Run the command 

Option1. Find the “Search text in drawings” button on the tool bar
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Click the “Setting” button to find more compare options. 

Click “OK” to compare and highlight differences in two drawings. 

Text searching in AutoCAD drawing 

No matter it is note, title block, or with pointer, DWGSee will help you locate and highlight it in the center of the 

the right pane, you may select “Case Sensitive” and “Match Whole Word” to rest

Hold “Ctrl” and press “B” to go to the Browser mode. 

Option1. Find the “Search text in drawings” button on the tool bar 

 

http://www.autodwg.com 

 

No matter it is note, title block, or with pointer, DWGSee will help you locate and highlight it in the center of the 

the right pane, you may select “Case Sensitive” and “Match Whole Word” to restrict 
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Option2. Right click in the view, and find the “Search text in drawings” item

Option3. Right click on a drawing thumbnail and find the “Search text in drawings” item

 

STEP3. 

Type the test, choose a destination folder and click “OK”.
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Option2. Right click in the view, and find the “Search text in drawings” item 

 

Option3. Right click on a drawing thumbnail and find the “Search text in drawings” item

 

Type the test, choose a destination folder and click “OK”.  

 

http://www.autodwg.com 

Option3. Right click on a drawing thumbnail and find the “Search text in drawings” item  
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STEP4. 

Double click on a drawing thumbnail to view the drawing. Use arrow button on the toolbar to switch drawings.

Note: You may want to search again in the drawing to locate the specific text in a drawing, please see >> Search 

and find text in the drawing. 

Example 

I searched a keyword and it gives me 2 results. Double clicked one file and open the drawing.

Now use the arrow buttons “Next drawing” and “Previous drawings” to browse all the matched drawings for 

reviews. 

To precisely locate a keyword, hold “Ctrl” and press “F” to find the text location in the drawing.

 

� Counting blocks, symbols, entities in a drawing

Have you been wondering how many widget blocks are in your drawing? You can mark the entities or blocks by 

checks, and count the number of checks you made. When symbols and attributed blocks use your drawing, it can 

be automatically checked. Attribute definiti

 

Here we go. 

      

STEP1. 

Please Open the drawing and find the “Count Items” on the toolbar.

STEP2. 

Find the “New” button to define a new group of entities.

Name the group and type it into the “Item Name” box, to count all the instances of same block in the drawing. 

Check the “Search and check all similar items”

AutoDWG DWGSee DWG Viewer 
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Double click on a drawing thumbnail to view the drawing. Use arrow button on the toolbar to switch drawings.

 

You may want to search again in the drawing to locate the specific text in a drawing, please see >> Search 

I searched a keyword and it gives me 2 results. Double clicked one file and open the drawing.

Now use the arrow buttons “Next drawing” and “Previous drawings” to browse all the matched drawings for 

hold “Ctrl” and press “F” to find the text location in the drawing.

Counting blocks, symbols, entities in a drawing 

Have you been wondering how many widget blocks are in your drawing? You can mark the entities or blocks by 

checks you made. When symbols and attributed blocks use your drawing, it can 

be automatically checked. Attribute definition is not required for blocks, nest blocks and Xref blocks are supported.

the “Count Items” on the toolbar. 

Find the “New” button to define a new group of entities. 

Name the group and type it into the “Item Name” box, to count all the instances of same block in the drawing. 

Check the “Search and check all similar items”, and click “OK”. 

http://www.autodwg.com 

Double click on a drawing thumbnail to view the drawing. Use arrow button on the toolbar to switch drawings.

You may want to search again in the drawing to locate the specific text in a drawing, please see >> Search 

I searched a keyword and it gives me 2 results. Double clicked one file and open the drawing.  

Now use the arrow buttons “Next drawing” and “Previous drawings” to browse all the matched drawings for 

hold “Ctrl” and press “F” to find the text location in the drawing. 

Have you been wondering how many widget blocks are in your drawing? You can mark the entities or blocks by 

checks you made. When symbols and attributed blocks use your drawing, it can 

and Xref blocks are supported. 

 

Name the group and type it into the “Item Name” box, to count all the instances of same block in the drawing. 
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STEP3. 

Get back to the drawing and you will find that when the mouse hovers, the mouse arrow will turn into a square 

or a gray mark sign.  

When it sniffers a block entity, the mouse shape turns into a square, in this way, you may click

and DWGSee will count out how many times the selected block are instanced in the drawing. You may find the 

calculated quantity shown in the “Counter Manager”. A green mark sign will then be added to each counted 

block on the screen.  

AutoDWG DWGSee DWG Viewer 
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Get back to the drawing and you will find that when the mouse hovers, the mouse arrow will turn into a square 

When it sniffers a block entity, the mouse shape turns into a square, in this way, you may click

and DWGSee will count out how many times the selected block are instanced in the drawing. You may find the 

calculated quantity shown in the “Counter Manager”. A green mark sign will then be added to each counted 

http://www.autodwg.com 

Get back to the drawing and you will find that when the mouse hovers, the mouse arrow will turn into a square 

When it sniffers a block entity, the mouse shape turns into a square, in this way, you may click the mouse key 

and DWGSee will count out how many times the selected block are instanced in the drawing. You may find the 

calculated quantity shown in the “Counter Manager”. A green mark sign will then be added to each counted 
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Note: To better help getting an accurate result, it is suggested to use your mouse wheel to zoom in before you tick 

on screen. 

 

STEP4. 

A gray mark sign allows you to select a single entity. If you want to add more entities to a same group, just tick the 

blocks individually as you want and DWGSee will continue counting the number.

 

� Copy the vector drawing into a Word document

Raster image can be inserted as vector image in MS Word. Creating WMF/EMF figures for MS Office, you can 

copy any part of your DWG, DXF and DWF drawing to the MS Word document and remain it to be measurable...

 

Here we go. 

 

STEP1. 

You have 3 options to call the copy function from DWGSee:

Option1. Go to “Edit” and find the copy options.
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To better help getting an accurate result, it is suggested to use your mouse wheel to zoom in before you tick 

A gray mark sign allows you to select a single entity. If you want to add more entities to a same group, just tick the 

as you want and DWGSee will continue counting the number.  

 

Copy the vector drawing into a Word document 

Raster image can be inserted as vector image in MS Word. Creating WMF/EMF figures for MS Office, you can 

and DWF drawing to the MS Word document and remain it to be measurable...

You have 3 options to call the copy function from DWGSee: 

Option1. Go to “Edit” and find the copy options. 

 

http://www.autodwg.com 

To better help getting an accurate result, it is suggested to use your mouse wheel to zoom in before you tick 

A gray mark sign allows you to select a single entity. If you want to add more entities to a same group, just tick the 

Raster image can be inserted as vector image in MS Word. Creating WMF/EMF figures for MS Office, you can 

and DWF drawing to the MS Word document and remain it to be measurable... 
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Option2. Right-click on the drawing and find the 

Option3. Hold “Ctrl” and press “C” to copy the current view or hold “Ctrl” and press “R” to copy a certain part of the 

drawing in clipboard. 

STEP2. 

Go to your MS document, and paste the vector image there.

 

Options 

 

� External reference (Xref) 

Xref is an external reference to another AutoCAD drawing file. One drawing can refer many other files and display 

them as one. If messages like below pops up when you open a drawing file in DWGSee, you’ll need to load the 

Xref manually, or it’ll become incomplete.

 

Here we go. 

 

STEP1. 

Go to “Options” > “Xref Manager”, you will find all the referenced files in the “Xref Manager” and the status is “Not 

Found” 
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click on the drawing and find the copy options. 

  

Option3. Hold “Ctrl” and press “C” to copy the current view or hold “Ctrl” and press “R” to copy a certain part of the 

Go to your MS document, and paste the vector image there. 

Xref is an external reference to another AutoCAD drawing file. One drawing can refer many other files and display 

them as one. If messages like below pops up when you open a drawing file in DWGSee, you’ll need to load the 

ome incomplete. 

 

Go to “Options” > “Xref Manager”, you will find all the referenced files in the “Xref Manager” and the status is “Not 

http://www.autodwg.com 

Option3. Hold “Ctrl” and press “C” to copy the current view or hold “Ctrl” and press “R” to copy a certain part of the 

Xref is an external reference to another AutoCAD drawing file. One drawing can refer many other files and display 

them as one. If messages like below pops up when you open a drawing file in DWGSee, you’ll need to load the 

Go to “Options” > “Xref Manager”, you will find all the referenced files in the “Xref Manager” and the status is “Not 
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STEP2. 

Option1. Put the drawing together with all the external references drawings. 

Option2. Choose every reference file in the list and click “Browse” to re
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Option1. Put the drawing together with all the external references drawings.   

 

Option2. Choose every reference file in the list and click “Browse” to re-locate the reference file.
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locate the reference file. 
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When the Xref file is selected, click “Save Path” to update the status.
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When the Xref file is selected, click “Save Path” to update the status. 
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Option3. Go to “Options” > “Font/Xref path…”

Click “Add” and choose th Xref’s location, then click “OK” to apply.

STEP3. 

You may need to close the drawing and restart DWGSee again, there won’t be a error message as Xrefs are all 

loaded. 
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